Back to overview
Unable to create a new sheet
Dec 19 at 11:21am GMT
Affected services
Orca Scan API
Resolved
Dec 19 at 11:21am GMT
We're working hard to restore the create sheet functionality.
Affected services
Orca Scan API
Resolved
Dec 19 at 11:21am GMT
We're working hard to restore the create sheet functionality.
Affected services
Orca Scan API